ISL Western EU Performance Degradation

Incident Report for Smart Cloud

Resolved

This incident has been resolved.
Posted May 20, 2026 - 19:35 UTC

Monitoring

Service appears to be operating as expected and AWS DR has been disabled. We will continue to monitor the situation for any anomalies.
Posted May 18, 2026 - 21:09 UTC

Investigating

Western EU performance is in a degraded state, as such we have elected to enable AWS DR licensing server.
Posted May 18, 2026 - 19:37 UTC
This incident affected: Intergraph Smart Licensing (West Europe, South East Asia, East US).